Online Learning Academy - LearnAcad.com

... Sharing Knowledge

  • Increase font size
  • Default font size
  • Decrease font size
Home

How to downgrade RPM Package using YUM?

E-mail Print PDF

1) Check Already Installed RPM and Required RPM

Following command will check which rpm version is installed.

rpm -qa | grep php

2) Install YUM Plugin

Issue following command to install yum-allowdowngrade plugin

yum -y install yum-allowdowngrade

3) Downgrade RPM Install

First you should be sure what rpm’s you are going to downgrade. For my list I will using already install PHP rpm package name with downgrade argument, which let yum to automatically use the lower version to install and remove the current version of PHP.

yum downgrade php-dba php-soap php-ldap php-mysql php-mcrypt php-common php-cli php-gd php-odbc php-xmlrpc php-snmp  php-bcmath php-imap- php-devel php-pdo php php-pgsql php-pgsql php-mbstring php-xml

Which was than verified using following commands

rpm -qa | grep php

shows install php rpm with version, additionally you can use php command with version option

php -v

If you have any question please comment.

Last Updated on Thursday, 25 October 2012 11:03  
Follow us on Twitter

Main Menu

Linux

Islam

Windows

Interview Questions

Database

Internet

Cisco

Entertainment

Networking

Graduate Courses

Psychology

Feed Burner

Subscribe to Welcome to Online Learning Academy by Email

Enter your email address:

Delivered by FeedBurner


Google Groups
Subscribe to LearnAcad
Email:
Visit this group

Login Form