VTP and InterVLAN Configuration in Packet Tracer
VTP and InterVLAN Configuration in Packet Tracer
1- Set vtp mode server on S1
Switch(config)#vtp mode server
2- Set vtp domain cisco on S1 (domain is case sensitive)
Switch(config)#vtp domain cisco
3- Set vtp version 2 on S1
Switch(config)#vtp version 2
4- Set vtp mode client on client switches (S2 and S4)
Switch(config)#vtp mode client
5 – Set vtp mode transparent on S3
Switch(config)#vtp mode transparent6- Set S1 trunk ports as point to point links Port fa0/22 to fa0/24
Switch(config)#int range fa0/22 -24
Switch(config-if-range)#switchport mode trunk
7- Create Vlan 10,20,30 on Server (S1) and set vlan name as previous
Basic vlan Lab and check the vtp status on server and other client switches.
Switch(config)#vlan 10
Switch(config-vlan)#name student
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name faculty
Switch(config-vlan)#vlan 30
Switch(config-vlan)#name guest
8-To verify Vlan and VTP status on all switches as
Switch# show vlan brief
Switch# show vtp status
Note: S1 and S2 shows Vlan but S3 and S4 not shows because Between S3 and
S4 Trunk is not established and domain and version in not eable on S3.
To verify trunk on S4
Switch# show int trunk
9- Configure trunk on S4 (because we configure trunk one side other side automatically make trunk)
Switch(config)#int fa0/23
Switch(config)#switch mode trunk
10- Configure VTP domain cisco on Transparent switches and version 2 as in step 2 and step 3
11 – Check Vlan and VTP status on S4 that shows the Vlan that are configured on
S1 Server.But not shows on S3 because it is transparent only forward the vlan .
11- Create vlan 40,50,60 on Transparent switch and set name.
Switch(config)#vlan 40
Switch(config-vlan)#name admin
Switch(config-vlan)#vlan 50
Switch(config-vlan)#name CS
Switch(config-vlan)#vlan 60
Switch(config-vlan)#name Account
12- Finally set port membership for VLAN PC on S2 and S3
Switch(config)#interface range fa0/1 – 5
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 10
Switch(config)#interface range fa0/6 – 10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 20
Switch(config)#interface range fa0/11 – 15
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 30
13- Set port membership on S3 for vlan 40,50,60
Switch(config)#interface range fa0/1 – 5
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 40
Switch(config)#interface range fa0/6 – 10
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 50
Switch(config)#interface range fa0/11 – 15
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 60
14- IP address and default gateway are already set on host.
Check within a vlan communication is ok if not check problem.
15- For Intervlan Routing I Use Router On Stick Method for All VLAN
1)Access Router and configure inter vlan for all vlan included native Vlan
Router>en
Router#config terminal
Router(config)#interface fa0/0
Router(config-if)#no shutdown
Note : Dont Set ip address on physical interface
Create Logical Interface for each VLAN as below
Router(config-if)#int fa0/0.10 (Sub Interface)
Router(config-subif)#encapsulation dot1Q 10 (Trunk for Vlan 10)
Router(config-subif)#ip address 192.168.10.254 255.255.255.0
Router(config-if)#int fa0/0.20
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip address 192.168.20.254 255.255.255.0
Note : COnfigure subinterface for VLAN 30,40,50,60 as above steps
For Native Vlan communication with other vlan configure as below
Router(config-subif)#int fa0/0.1
Router(config-subif)#encapsulation dot1Q 1 native (default native vlan is 1 )
Router(config-subif)#ip address 192.168.1.254 255.255.255.0
16- Now check Intervlan communication ping pc1 to pc2.
17) Verification on Router use command on privilige mode
I) show ip interface brief
ii)show ip route
iii) Show run
iv)show interfaces
v) show arp
18- Other useful Commands
i) Set Vtp password cisco on all switches
Switch(config)#vtp password cisco
If password are different vtp information are not synchronized.
ii)Set ip address on Logical interfaces for VLAN 10,20,30 server
Switch(config)#interface vlan 10
Switch(config-if)#ip add 192.168.10.253 255.255.255.0
Switch(config-if)#no shutdown
set for vlan 20 and 30 and use network 192.168.20.0 and 192.168.30.0
19)delete VLAN on server and check it is removed from client
Switch(config-vlan)#no vlan 30
(It is enough Check the output and learn it)